Windows 8.1

Oct 28, 2013 at 9:42 PM
Is it possible to target this to Windows 8.1?

Thanks
Coordinator
Oct 29, 2013 at 10:15 AM
SQLite has not provide a release version of its database engine (it's still in preview)
I will publish a compatible version if you need it and can't wait :)
Oct 29, 2013 at 10:02 PM
It would be great if you can publish a compatible version for 8.1 with the preview! that would help a lot.

Thanks again!
Coordinator
Oct 30, 2013 at 2:07 PM
Here is the documentation on "How test the 8.1 version" :

http://syncwinrt.codeplex.com/wikipage?title=w81temp
Oct 30, 2013 at 5:01 PM
Great! Thanks!
Nov 4, 2013 at 3:21 PM
I am getting this error when working with 8.1. Any ideas? Do you have a working sample project?
Exception thrown: "The specified buffer index is not within the buffer capacity"
Exception thrown: "Specified uri does not match uri previously used for the specified database"
Thanks for your help
Coordinator
Nov 4, 2013 at 6:20 PM
Yes, your local sqlite database is configured for 1 server url.

If you change the server url you should:
  • Delete the database and re-sync
  • Update the sync local table to match correct uri
  • Create an other Scope
Nov 5, 2013 at 10:37 PM
Thanks! the issue is resolved now!
Dec 5, 2013 at 8:04 PM
Hi Mimetis/gomzig,

I have a similar issue that has got me scratching my head for so long.
I have implemented WinRt sync framework . The frame work creates local db and works fine when I run the app and sync for the first time. when I rerun the app it throws an error.

Exception Details:

System.ArgumentException was unhandled by user code HResult=-2147024809 Message=____Specified offlineSchema does not match database Offline schema previously used for cache path

Thanks for any help.
Coordinator
Dec 6, 2013 at 1:20 PM
Can you share with me your solution (if it's possible for you) ?
Dec 7, 2013 at 6:38 PM
Mimetis wrote:
Can you share with me your solution (if it's possible for you) ?
Hi Mimetis,

I was able to sort this out. It had nothing to do with the code. A few tables in my db started with cap. I changed all to small letter.

Thanks for the great work.